ShipEngine Outage
Incident Report for ScriptDrop
Resolved
ShipEngine has pushed a fix.
Posted Sep 26, 2024 - 15:34 EDT
Investigating
Currently ShipEngine is having an outage which is impacting the creation of shipping orders
Posted Sep 26, 2024 - 12:30 EDT
This incident affected: Portal and APIs.