Degradation of Services

Incident Report for ScriptDrop

Resolved

Performance has returned to normal.
Posted Jul 10, 2025 - 17:18 EDT

Investigating

The ScriptDrop app is experiencing some degradation due to upstream services having issues. We are investigating and will provide updates as we get them.
Posted Jul 10, 2025 - 15:56 EDT
This incident affected: Portal and APIs.